CMaNGOS - WoW Emulation
database issue - creature_equip_template empty - Printable Version

+- CMaNGOS - WoW Emulation (https://oldforum.cmangos.net)
+-- Forum: Help & Support Forum (https://oldforum.cmangos.net/forum-4.html)
+--- Forum: Installation, Configuration & Upgrades (https://oldforum.cmangos.net/forum-5.html)
+--- Thread: database issue - creature_equip_template empty (/thread-7822.html)



database issue - creature_equip_template empty - RichardGe - 03-26-2017

Hi,

I have several database warnings when I start mangosd.exe

most of the warnings are :
Table creature_template have creature <Entry: xxxxx > with equipment_id xxxxx not found in table 'creature_equip_template' set to no equipment.

the thing is, my creature_equip_template table is empty
( however, my creature_equip_template_raw is not empty... don't know what this means )

I'm searching everywhere where is the script that initialize the creature_equip_template table. but I don't find this sql script.

I also have lots of Warning talking of :
Table creature have creature with 'creature_template'.'regenarateStats' & REGEN_FLAG_HEALTH and low current health (xxx) creature_template.MinLevelHealth=3758

Maybe I'm missing some update scripts that need to be run..

Note that I would like to update my database without re-initialize it

Thank you


RE: database issue - creature_equip_template empty - RichardGe - 03-27-2017

I have cleaned and reinstalled everything (database & executable) from latest git version, now it really works better.

I have "only" 18 ERROR during initialization, but maybe those are known issues...

I'm joining the server log if someone wants to have a look. I would be interested to know if it's expected or not

Thanks