Fork me on GitHub
Classic [FIXED] Fresh install database error
Post: #1
Hi, I tried to install last night but I get the following when I run InstallFullDB:

Code:
Process classic database v1.4.2 'High Elves, Thaurissan and Necromancers in a Sw
imming Pool.'
Warning: Using a password on the command line interface can be insecure.
Process database updates
./InstallFullDB.sh: line 124: [: too many arguments
  process update updates/0907_creatue.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0907_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0908_gameobject_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0909_npc_trainer.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0910_creature_movement_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0911_creature.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0912_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0913_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0914_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0915_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0916_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0918_creature_movement_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0919_creature_movement_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0920_creature.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0921_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0922_creature_model_info.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0923_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0924_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0925_dbscripts_on_go_template_use.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0926_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0927_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0928_creature_linking.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0929_creature_equip_template_raw.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0930_creature_linking_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0931_creature.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0932_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0933_creature_linking_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0934_creature_movement.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0935_dbscripts_on_quest_start.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0936_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0937_creature_linking.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0938_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0941_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0942_dbscripts_on_quest_end.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0943_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0943_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0944_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0945_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0945_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0946_creature_involvedrelation.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0946_creature_questrelation.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0947_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0948_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0950_creature_movement_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0951_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0952_creature_linking_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0953_gameobject.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0954_creature.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0955_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0956_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0957_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0958_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0959_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0960_quest_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0961_creature_ai_scripts.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0961_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0962_creature_movement.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0963_creature_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0964_dbscripts_on_go_template_use.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0965_creature.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0967_item_loot_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0968_npc_vendor.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0969_dbscripts_on_go_template_use.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0970_gameobject_loot_template.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0972_z2612_s2254_12816_01_mangos_command.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0972_z2612_s2254_12816_02_mangos_mangos_string.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0973_z2619_s2261_12821_01_mangos_command.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0974_z2621_s2263_12823_01_mangos_command.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0974_z2621_s2263_12823_02_mangos_creature_movement.sql

Warning: Using a password on the command line interface can be insecure.
  process update updates/0974_z2621_s2263_12823_03_mangos_creature_movement_tem
plate.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0974_z2621_s2263_12823_04_mangos_creature.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0975_r2717_mangos.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0976_r2718_mangos.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0977_r2729_mangos.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0978_dbscripts_on_quest_end.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0979_spell_script_target.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0980_dbscripts_on_go_template_use.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0982_dbscripts_on_quest_start.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0983_tribute_run.sql
Warning: Using a password on the command line interface can be insecure.
  process update updates/0984_creature_loot_template.sql
Warning: Using a password on the command line interface can be insecure.
Updates applied


Applying additional core updates from path /c/Mangos/mangos

Append core update z2612_s2254_12816_01_mangos_command.sql to database mangos
Warning: Using a password on the command line interface can be insecure.
ERROR 1054 (42S22) at line 1: Unknown column 'required_z2533_sxxxx_xxxxx_01_mang
os_spell_chain' in 'db_version'
Reply
Post: #2
My mistake, I forgot to update the revision numbers in Classic DB. It will be fixed soon.
Anyway, you don't need to add the core SQK updates at the moment: Classic DB and CMaNGOS Classic core are up-to-date. So remove the core updates path in your InstallFullDB.config and run the script again.
Reply
Post: #3
Fixed in https://github.com/classicdb/database/co...4c6b97eaf6
Reply
Post: #4
Thanks for the fix, very helpful.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Ubuntu install instructions for beginners adellaci 74 25,358 04-10-2017, 02:24 PM
Last Post: marvello124
  database issue - creature_equip_template empty RichardGe 1 808 03-27-2017, 05:33 PM
Last Post: RichardGe
  [TBC] VMAPS ERROR HNDRXX 3 1,182 03-26-2017, 08:27 AM
Last Post: HNDRXX
  [CLASSIC] make error gorgau 1 701 03-10-2017, 06:39 AM
Last Post: JoseQ
Exclamation [CLASSIC] Playerbot database error? Do I have the wrong classic-db? Wingblade 0 619 02-21-2017, 05:01 PM
Last Post: Wingblade
  [TBC] Compilation error: linking buddiman 1 885 12-20-2016, 01:29 PM
Last Post: evil@wow
Question [TBC] Cmangos TBC where to download the latest full database ft2085267 5 3,008 11-23-2016, 04:55 AM
Last Post: demago
  [CLASSIC] InstallFullDB.sh error 1054 Wingblade 8 2,606 11-10-2016, 05:55 PM
Last Post: Wingblade
  latest cmangos classic with playerbot compile error darkdandy 2 1,261 10-27-2016, 02:34 PM
Last Post: darkdandy
  [TBC] TBC-DB proper install method? No item loot from ceratures! mrC 1 1,110 10-17-2016, 05:11 PM
Last Post: JoseQ

Forum Jump:


Users browsing this thread: 1 Guest(s)

Continued MaNGOS | Return to Top | | Lite (Archive) Mode | RSS Syndication