Fork me on GitHub
Classic Fresh Install - SQL scripting issue?
Post: #1
Using the main installation guide athttps://github.com/cmangos/issues/wiki/I...structions (ClassicDB on Windows).

Made it all the way down through the SQL scripting section without any problemsand now have 2 questions/issues:
  • When doing the step for "./InstallFullDB.sh", I get:
    Code:
    Applying additional core updates from path ../../mangos

    ./InstallFullDB.sh: line 182: [: *_*_mangos_*.sql: integer expression expected
    All core updates applied

    You have now a clean and recent classic DB database loaded into mangos
    Enjoy using classic DB


  • Then, when I go to run mangosd.exe, I get:
    Code:
    Using configuration file mangosd.conf.
    OpenSSL 1.0.0d 8 Feb 2011 (Library: OpenSSL 1.0.0d 8 Feb 2011)
    Using ACE: 5.8.3
    World Database total connections: 2
    Connected to MySQL database mangos@127.0.0.1:3306/mangos
    MySQL client library: 5.1.49
    MySQL server ver: 5.6.26-log
    AUTOCOMMIT SUCCESSFULLY SET TO 1
    Connected to MySQL database mangos@127.0.0.1:3306/mangos
    MySQL client library: 5.1.49
    MySQL server ver: 5.6.26-log
    AUTOCOMMIT SUCCESSFULLY SET TO 1
    SQL: SELECT required_z2681_01_mangos_mangos_string FROM db_version LIMIT 1
    query ERROR: Unknown column 'required_z2681_01_mangos_mangos_string' in 'field
    ist'
    The table `db_version` in your [WORLD] database indicates that this database is
    out of date!

    [A] You have: --> `z2674_sxxxx_xxxxx_01_mangos_creature_template.sql`

    [B] You need: --> `z2681_01_mangos_mangos_string.sql`

    You must apply all updates after [A] to [B] to use mangos with this database.
    These updates are included in the sql/updates folder.
    Please read the included [README] in sql/updates for instructions on updating.



What am I forgetting? Certainly it should be doing all the updates automatically (instead of running all the update scripts individually)

Thanks in advance!
Reply
Post: #2
Went to go check, and looks like I'm really only missing 7 updates from the newest 0.12.3 SQL update folder.

Figured I could apply those 7 manually through MySQL, but bombed on trying to do the first one
Code:
z2678_01_realmd.sql

Trying to run that query againstthe realmd database returned
Code:
Error Code: 1054. Unknown column 'required_10008_01_realmd_realmd_db_version' in 'realmd_db_version'
Reply
Post: #3
OK, still not exactly sure of root cause (what caused the last few SQL updates to fail), but have mangosd.exe running now.

Based on the error message I received when trying to run mangosd.exe, I should have needed to run
Code:
z2678_01_realmd.sql
z2678_02_characters.sql
z2678_03_mangos.sql
z2679_01_characters_guild.sql
z2679_03_characters_guild_member.sql
z2680_01_mangos_battleground_template.sql
z2681_01_mangos_mangos_string.sql
I went in and tries to do the SQL scripts 1 by 1, and it appears as through the Character DB scripts did previously run OK by themselves (they were already done).
When I ran each of the mangos DB update scripts, they ran successfully, so not sure why they didn't run by themselves before. However, after I ran those 3 mangos DB scripts, mangosd.exe is now running.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Ubuntu install instructions for beginners adellaci 74 25,358 04-10-2017, 02:24 PM
Last Post: marvello124
  database issue - creature_equip_template empty RichardGe 1 808 03-27-2017, 05:33 PM
Last Post: RichardGe
  [CLASSIC] Issue with Extracting Wrsx 1 876 12-20-2016, 02:08 PM
Last Post: Cyberium
  [TBC] TBC-DB proper install method? No item loot from ceratures! mrC 1 1,110 10-17-2016, 05:11 PM
Last Post: JoseQ
  ScriptDev2 Build issue wyattdumas 3 1,751 07-22-2016, 01:42 AM
Last Post: wyattdumas
  [CLASSIC] Compile issue on Linux w/GCC 6.1? liko 5 2,850 07-05-2016, 04:38 PM
Last Post: adellaci
  Issue with DB \base installation Zodir 5 2,588 05-30-2016, 06:56 AM
Last Post: Lankytim
  [TBC] Windows_Install_Script.bat issue Farkie 14 6,234 01-21-2016, 03:19 AM
Last Post: Lankytim
  [WOTLK] Successful Install Yllidor 4 3,439 07-30-2015, 09:28 PM
Last Post: Yllidor
  [CLASSIC] [FIXED] Fresh install database error Viela 3 3,592 07-21-2015, 09:36 AM
Last Post: goandgo

Forum Jump:


Users browsing this thread: 1 Guest(s)

Continued MaNGOS | Return to Top | | Lite (Archive) Mode | RSS Syndication