Fork me on GitHub
Issue with DB \base installation
Post: #1
Sorry to bother you with a noob question. I played, a while ago now, with arcemu for WOTLK and few weeks ago I decided to start again a WoW server to play with old school friends (we are all close to 40... no joke) on LAN. I discovered that the WoW emu landscape as quite evolved since then, and that's excellent to see people like you who committed to maintain it.

In brief I followed the installation guide which seems a bit outdated (fortunately some smart guy such as MadMax have produced useful updates) and I am able to have the core code downloaded, compiled without error, the DB downloaded but I am currently facing issue with the installation of the base DB.

realmd, characters, mangos DBs are created without error on mySQL server instance from /sql/base folder (I am using SQLyog as client) but when it comes to populate the DB from /sql/base here comes the headache.

for each line containing ...Engine=InnoDB DEFAULT CHARSET=utf8; mySQL seems not happy and report error. After readings on mySQL support it appears to be the default Engine and not need to be precised. So Notepad++ is your friend and I removed the Engine=InnoDB from files and the import went file for characters and mangos.
Problem now is with realmd DB which claim that `realmd_db_version` table does not exist which seems wrong from SQLyog ...

Question what am I doing wrong ? does each file need fine tuning before processed with SQLyog ? I am bit lost (maybe too old for this :-))
Thank you for your help on the matter.
Post: #2
The initial population of the databases, applying the required updates to get your core satisfied, then applying future fixes/updates can be a bit complex at first. Not sure about the character set problem... This would have been set if you used the create script, eg:

Usually when you see a "_version' table does not exist" it means the SQL you're trying to apply is an update and the expected previous version of the DB is not there (ie. missing previous updates).

I don't know about Classic, but the DBs for TBC and WotLK both come with a tool can be used to apply the database and updates for the world DB (including core updates and ACID) somewhat automagically. Refer to and
Post: #3
Thank you Lankytim for your answer,

Well reading again what I wrote is not very clear at all (my English is pity)...

To clarify (try at least) creation of DBs went fine using /sql/create/*.sql files and ran without error.
When I tried to initialize the DBs using /sql/base/*.sql files I got the Engine=InnoDB SQL error message, solved when I removed the parameter from the file. The second initialization failed with the "_version' table does not exist"

I will start again the DBs installation/upgrade process later this week to see what I doing wrong and will check your links for the tools.
Anyway, thank you again.
Post: #4
I missed your reference to the MySQL storage engine before. Did you select a different engine during the MySQL server installation wizard? If you can't force use of the InnoDB engine as a startup option, maybe you have to run the installation wizard again to make it available?

I can't give any advice about which storage engine you should use, but if CMaNGOS is asking/expecting InnoDB, then for me InnoDB is what it gets Smile

Good luck with your start-over. Let us know how you go.
Post: #5

I've just restarted uniquely the sql part installation for the ClassicDB on an old laptop. In brief a Win7x64, a MySQL 5.7 with MySQL Workbench 6.3.6 and Git 2.8.3x64

The file db_create_mysql.sql from /mangos/sql/create was imported successfully and the three empty DBs were created, then each DB was initialized successfully with files located in /mangos/sql/base
(all was done with MySQL Workbench - don't forget to right click each DB (characters,mangos,realmd) and "Select as default Schema before running each script or it fails) - so far so good.

For the classicDB its another story :-))
From your advises, I 've searched for tools supporting the DB update and for classic they exist as well (I was blind somehow) very fortunately.

In the /Mangos/classicDB/ folder the script does the trick (From Git Bash - run it once, modify InstallFullDB.config newly created & re-run it).
[Windows] Don't forget to add C:\Program Files\MySQL\MySQL Server 5.7\bin in PATH Environment Variables to support the execution of (the config file asks for MYSQL command and if it is not provided by PATH variable every new execution will fail with the stupid "command not found" message when it starts to upload data :-)

I finally had to run the script from a Git bash because the import of "ClassicDB_1_6_5z2683.sql" (42MB) in MySQL Workbench result in total hang off and a "Not Responding Application" message even waiting 5min

So, summarized I have a characters, a realmd and a mangos database and their tables seem filled from an SQL perspective. Moving to compile the mangosd, realmd to check how to manage DB update process.

Would be cool to have an updated install tuto for noobs like me, it might help (if I am not so wrong everything exists already on that forum but the info is scattered among posts)

Any way thank you for your post, it advised me on many points, was rich in information and made me progress ! well done ;-)
[-] The following 1 user says Thank You to Zodir for this post:
  â€¢ Lankytim
Post: #6
I'm glad to hear that you found the advice helpful and you were able to progress your installation. I am also a noob around here but I try to help where I can. Thanks for posting your feedback.

Possibly Related Threads...
Thread Author Replies Views Last Post
  database issue - creature_equip_template empty RichardGe 1 805 03-27-2017, 05:33 PM
Last Post: RichardGe
  [TBC] Proper DB Installation Spark 3 1,534 03-24-2017, 01:55 PM
Last Post: Alaeria
  [CLASSIC] Issue with Extracting Wrsx 1 876 12-20-2016, 02:08 PM
Last Post: Cyberium
  ScriptDev2 Build issue wyattdumas 3 1,749 07-22-2016, 01:42 AM
Last Post: wyattdumas
  [CLASSIC] Compile issue on Linux w/GCC 6.1? liko 5 2,848 07-05-2016, 04:38 PM
Last Post: adellaci
  [CLASSIC] [First Installation] Server logs forever zallek 3 2,061 05-30-2016, 09:47 AM
Last Post: shiendra
  [TBC] Windows_Install_Script.bat issue Farkie 14 6,232 01-21-2016, 03:19 AM
Last Post: Lankytim
  Need Help With Installation Naisha 1 1,952 12-18-2015, 05:35 AM
Last Post: Hauntedwebby
  [CLASSIC] SD2 with new installation Zingzah 3 2,512 11-02-2015, 05:14 PM
Last Post: ViOTeK
  [CLASSIC] Fresh Install - SQL scripting issue? pillbug22 2 2,296 09-16-2015, 01:20 AM
Last Post: pillbug22

Forum Jump:

Users browsing this thread: 1 Guest(s)

Continued MaNGOS | Return to Top | | Lite (Archive) Mode | RSS Syndication